読者です 読者をやめる 読者になる 読者になる

requirements.txt を書いておく

Python

いつも忘れるので。

Python で作ったアプリが依存するライブラリは requirements.txt に記述しておく。

改行区切りで次のように。

requests==2.0.1

pip freeze で出力されるのが Python カレントな環境でインストールされているライブラリとバージョン。

pip install -r requirements.txt でインストールする。

参考

2012.05版 Python開発のお気に入り構成(ポロリもあるよ) - YAMAGUCHI::weblog